Jonjs' Blog Jonjs' Blog

外部协议打开外部程序及参数传入(易语言)(形如xyz://)

in 疯狂的文章 89个浏览 文章转载请注明来源!

最近一直想搞这个,一下子试验成功了,就来发个帖,避免以后频繁在其他网站上搜索,浪费时间。
试验完成后一定要清理一下你的注册表!
(2019/6/5更新)软件设计思路:时钟检测命令行是否被更改,被更改取新,并销毁新程序;未被更改则销毁新程序。

小提示:程序人为打开一次后可以写一次注册表,路径取运行目录+执行文件名即可,随机应变。

代码(例如在test://中,test就是头)

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\F1]
@="URL:头 Protocol Handler"
"URL Protocol"=""

[HKEY_CLASSES_ROOT\头\shell]

[HKEY_CLASSES_ROOT\头\shell\open]

[HKEY_CLASSES_ROOT\头\shell\open\command]
@="程序路径(双反斜杠) "%1""

外部参数传入程序:
例子:test://?hash=233
你需要在“_启动窗口创建完毕”子程序下写入以下代码,以便接收传入的参数:
(子程序代码)

.版本 2
.支持库 spec

    取命令行 (命令行数组)
    .判断开始 (取数组成员数 (命令行数组) = 0)
        调试输出 (“无参数”)
    .判断 (取数组成员数 (命令行数组) ≠ 0)
        调试输出 (“参数是:” + 命令行数组 [1])

(定义程序集文本型数组)

    .版本 2
    
    .程序集变量 命令行数组, 文本型, , "0"

外部访问1:test://?hash=233
参数接收1:test:///?hash=233(多一个/,所以别忘了替换一下)
外部访问2:test://model9s(必须以字母结尾)
参数接收2:test:///model9s/(后面多一个/,所以别忘了替换一下)

感谢阅读
资料引用:http://bbs.eyuyan.com/simple/?t306972.html

WeChat Pay

微信打赏

文章二维码

扫描二维码,在手机上阅读!

网络协议打开外部程序易语言
最后由Jonjs修改于2019-06-05 22:22
发表新评论
博客已萌萌哒运行
© 2019 由 Typecho 无力驱动.Theme by Yodu
雨云主机强力驱动
前篇 后篇
蕾姆
拉姆